Version "1-0-281 8397" Fails


Krillan

New member
Sep 8, 2020
1
0
I'm piggy backing on this thread that had its replies disabled. It's been 7 months with no update to the behavior to make it actually work. You mentioned that "if you try again, it should work" in your response Jeff, but it never works for me. On the first attempt for a new site, the app crashes; on subsequent attempts, I get a constant "Working..." spinner that flashes spastically. If you have a working version to release to Testflight ahead of the App Store version, I believe it would be prudent to release it while the App Store release continues forth.

Thanks much.
 

Jeffa

Well-known member
May 20, 2018
227
116
I'm piggy backing on this thread that had its replies disabled. It's been 7 months with no update to the behavior to make it actually work. You mentioned that "if you try again, it should work" in your response Jeff, but it never works for me. On the first attempt for a new site, the app crashes; on subsequent attempts, I get a constant "Working..." spinner that flashes spastically. If you have a working version to release to Testflight ahead of the App Store version, I believe it would be prudent to release it while the App Store release continues forth.

Thanks much.
Hi,

I am sorry your journey has not been as I would hope.

There is plainly a bug in the client you have, however this problem does not surface for all users. Have you set a default identity?

The “working” version is less complete than the one you already have, but for better or worse it is the version under current development.

I think I am going to update my invite script to add everyone that is an existing tester to the “new” version and to invite all new testers to the “new” version only.

The old client is working for many people, but it does not make sense for me to keep sending out the old one.

Anyone that has the old one and is using it can keep using it.

Thanks for your interest and support.
 

Beakerboy

New member
Dec 23, 2020
4
0
My client also crashes on every initial auth attempt. For example, I tried to register at this site. The app opened, I entered my master password, the app worked for a while, then crashed. If I try the authenticate the same QR code subsequent times, I get a spinning “working” image flashing on and off. I’m on version. 1-0-281 8398
 

Beakerboy

New member
Dec 23, 2020
4
0
I updated iOS this weekend, and tried the SQRL client again. It still crashes, but this time it asked if I would like a crash report sent to the developers. I’d love to help debug this when you have the chance to look at it. I feel this should be the future of web authentication, and the fact that there’s no usable iOS client saddens me.
 

Jeffa

Well-known member
May 20, 2018
227
116
Hi Beaker,

Sign up to the slack in my sig.

Thanks for your support and testing.

Jeff