Thoughts, Experiments, and Glitches


Status
Not open for further replies.
Mar 10, 2019
11
4
So, in many ways I feel I went about some of this backwards, so I may have some edge cases here. I'm a Mac user, with an iPhone -- but while I was waiting for the TestFlight invitation, I became impatient. I signed up for an account on this forum and looked around.

Then I installed Steve's SQRL client on a Windows 10 laptop that I rarely use. That experience was incredibly seamless, although when trying to examine what the QR code said via RedLaser and the iOS Camera app, it didn't seem to be able to pick up the QR code ...only the boundaries of it. It made me wonder if it was something about the QR code's contents or the screen refresh rate. (Hold that thought.)

Logging on with that newly created identity, the forums did allow me to associate my identity to my existing account -- though I had to enter the username and password for the forums twice. It wasn't clear why. But after doing so, Steve's client worked just like magic.

Then the TestFlight invitation showed up, and I installed Jeff's client. The trick now was to import my profile. Steve's client showed the URL, and it took me a moment to find the import area on the app. (It'd be nice to have something guiding one through the initial process after installation.) I pointed the app's camera at the QR code sitting on the Win 10 box and it worked like a champ. (Now I'm wondering why my other QR readers couldn't make sense of things.)

I then logged out of the forum, hit login, got the tiny URL code on the Mac, and pointed Jeff's client at it. Surprisingly, it took me to a page where it was asking for my username and password (and not an association page either). Weird.

I wondered if I had managed to import the new profile, but it wasn't made default (although it was the only one there). So, I went back, selected it, filled in the password, and GUI-wise there was pretty much a blank screen and a Back indicator. I think before putting this out for adoption, a very visual workflow will be required so that perceived "extra steps" aren't present or are at least explained.

Then, back on the forum I went to login again, and pointed Jeff's client at the QR code again. It asked me for my identity password again, which surprised me since I had just provided it moments ago when selecting it as the default. I then sat there as the client did more unlocking or such, and Jeff's client seemed to go idle. Meanwhile, nothing happened on the forum. I thought it was supposed to instantly jump to a login.

Enough time passed (maybe 10 seconds or so), I was about to conduct another test, when suddenly I found myself logged in.

I was about to go try Jeff's Python test server, but my browser it's happy about the certificate being out of date. (Steve, what's SQRL's behavior going to be if the user authenticates, but the site's certificate is stale?)

...off to more testing.
 
Status
Not open for further replies.