Release v1.1.1

  • New Wordpress Plug-In Forum
    Guest:

    Just a note that we have a new forum to contain discussions relating to the Wordpress plug-in which Daniel Persson originated and has been making great progress on. You'll find it under "Server-Side Solutions."

    /Steve.

kalaspuffar

Well-known member
May 19, 2018
269
91
Sweden
coderinsights.com
Hi gang.

After some improvements by @ahauser to the Android application, I was reminded about some implementation subtleties that I had forgotten and therefore I had to do a bugfix release of the plugin to handle these issues.

Hope the plugin handles more like you suspect it to work.

Bugfixes
* Handle CANcel parameter correctly.
* Remove should disassociate identity from the user
* Disable should only disable login with SQRL if not SQRLOnly is supplied.

Best regards
Daniel
 

bep69

New member
Jul 4, 2019
1
1
Hi, great work!
Installed v. 1.1.2.
I'm using the Android app. So, I scanned my WP site's QR code and entered the SQRL passcode (sometimes the first 4 chars seem to suffice).
Wordpress then goes to the main page.
Now, sometimes the login welcome message "Howdy, xxx" is shown, sometimes not. When it didn't show I pressed F5 (refresh) and then the welcome message was shown - so it logged me in correctly.
Once I got a "bad base=64" error - not quite sure why.

Thanks!
 
  • Like
Reactions: kalaspuffar

kalaspuffar

Well-known member
May 19, 2018
269
91
Sweden
coderinsights.com
Hi @bep69

Inconsistent login could be a caching issue so hopefully that will solve it self. But if you can find a way to reproduce it then I'll look into it.

The base64 issue is a bit more concerning. If you can reproduce it and see what the logs say then any info is helpful to find the reason.

Thank you for your time

Best regards
Daniel
 

berossm

New member
Sep 28, 2018
3
0
38
After upgrading version I found that I had to manually clear cache, prior to that I had been getting the attached protocol error.

It seems there is an issue with Object Caching with W3 Total Cache which was enabled by default by my provider.
499
 
Last edited: