Redirection to a URL afer log in.

  • New Wordpress Plug-In Forum
    Guest:

    Just a note that we have a new forum to contain discussions relating to the Wordpress plug-in which Daniel Persson originated and has been making great progress on. You'll find it under "Server-Side Solutions."

    /Steve.

brianoflondon

Well-known member
Nov 22, 2018
81
8
I'm not sure if this issue is part of Wordpress plug in or something @Steve needs to take a look at.

If a user logs in trying to leave a comment on a specific post it's going to be essential that they are taken straight back to the page they tried to log in from.

If I click on a "Log in to reply" link on a comment on my blog it gives me this URL:


Code:
https://brianoflondon.me/blog/wp-login.php?redirect_to=https%3A%2F%2Fbrianoflondon.me%2F2019%2F07%2Fsteve-gibson-s-sqrl-system-now-live-on-brianoflondon-me%2F
Which obviously contains everything necessary to get the user back to the right place.

I've got to say so far @kalaspuffar 's work has been amazing and such rapid progress means this is almost useable now!
 

PHolder

Well-known member
May 19, 2018
910
122
I attempted to use the GRC SQRL client, but all I get is an error message. Tried with both Firefox and Chrome.

476

I presume it might be that the plugin needs to be updated to match some of the recent bugfixes I read about elsewhere? Makes me wonder what all the other users have used, though?
 

brianoflondon

Well-known member
Nov 22, 2018
81
8
I'm seeing that quite a few people have created users so I suggest going back and just trying again or navigating to different pages on the blog and seeing if the bar appears at the top of the page indicating that you really are logged on.
 

PHolder

Well-known member
May 19, 2018
910
122
I'm seeing that quite a few people have created users
I created an account the old fashioned way... with email and confirmation message and then setting the password, wondering if associating my SQRL ID would work. That didn't work either.
 

kalaspuffar

Well-known member
May 19, 2018
267
91
Sweden
coderinsights.com
Hi @PHolder

Any more input? I've tried this feature locally with sites both with and without a path.

So any extra information you can give me on this bug really helps me figure out what might be the cause.

Best regards
Daniel
 

PHolder

Well-known member
May 19, 2018
910
122
Any more input?
@kalaspuffar Hey Daniel:

Sorry I was reacting to @brianoflondon wondering how some accounts were getting created... and wanted to let him know that I "manually" created mine, rather than use SQRL. I then did try again, and it seems that I was able to get it working... presumably after he updated to the latest version of the plugin. At this point, things seem to be working well with the limited amount of testing I've done. Good job, nice progress!
 
  • Like
Reactions: kalaspuffar