How do I get Google Chrome to stop prompting for permission to run SQRL?


Status
Not open for further replies.

Stephen Greeley

New member
Jul 16, 2019
2
0
I am using Steve's Windows SQRL app. In that context, I tested the SQRL setup page with Google Chrome; https://www.grc.com/sqrl/BrowserSetup.htm

While the scheme test link was successful, I am unable to get Google Chrome to stop prompting me to allow communication with the SQRL app. The browser setup page states:

If clicking the button above presents you with a warning or confirmation dialog notice from your browser, you should verify that your SQRL application will be launched by the sqrl:// scheme and, for convenience, you should probably instruct your web browser not to ask you every time (or ever again). This will allow you to enjoy seamless SQRL logons through this web browser.

So, how do I get my web browser to stop asking me every time? Google Chrome is not displaying an option to always allow.

I am using Google Chrome Release Version 80.0.3987.87

Thanks.
 
Last edited:

PHolder

Well-known member
May 19, 2018
1,232
205
Google Chrome is not displaying an option to always allow
It's a Chrome problem. There is nothing an external app can do. If Chrome doesn't want to offer the option not to prompt, then there is little anyone else can do.

You can read more here, particularly the second item at the bottom. Seems the Chrome devs think they know better what you want than you do.
 
  • Like
Reactions: Stephen Greeley

Dror Harari

Active member
Aug 10, 2019
26
6
'> It's a Chrome problem. There is nothing an external app can do
Actually down below in the above link they do offer a solution (seems like Chrome change was rolled back or at least scaled back)
 
  • Like
Reactions: Stephen Greeley

PHolder

Well-known member
May 19, 2018
1,232
205
I misunderstood the chronology apparently, I thought they had fixed it and then decided to break it again. I guess the question asker can try the proposed solution for their platform and decide for themselves if Chrome is worth the hassle. It certainly works better on Firefox.
 
  • Like
Reactions: Stephen Greeley

Stephen Greeley

New member
Jul 16, 2019
2
0
Thank you. The registry entry worked great. Now Steve's SQRL app works great without the annoying repeating prompts. Once you add the following registry entry you will be prompted for the first time but you can now select the Don't ask again check box and all works smoothly after that for that particular site.

The content of the reg file that fixes this is as follows:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome]
"ExternalProtocolDialogShowAlwaysOpenCheckbox"=dword:00000001

Thank you.
 

El Bastardo

New member
Feb 16, 2020
3
0
Hehe I just researched about this myself and found the same solution here:

This behavior is new since Chrome 77 and the policy was added in 79.

Use the URL "chrome://policy" to check that it is working correctly.

Bonus tip: If you are using "Vivaldi" like I am, change the key to [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Vivaldi]
 

PHolder

Well-known member
May 19, 2018
1,232
205
Thank you for that useful info. If you click the link attached to the policy in the chrome://policy page (search for ExternalProtocol) you get linked to the same link you provided above, which bears repeating:

 
Status
Not open for further replies.