Browser Plugins onPasswdFormSubmit ERRPFS--2


Ipomoea

Member
May 20, 2020
8
0
Hello,

I am trying to add SQRL authentication to my web project but keep running into the following error when trying to log in using the Firefox browser plugin.
Code:
onPasswdFormSubmit

ERRPFS--2

Unknown error code malformed URI sequence

I get a similar message on Chrome:
Code:
onPasswdFormSubmit

ERRPFS--2

Unknown error code ERRFE002
While Firefox only logs me in 10th try or so Chrome always logs me in even though the error is showing.
I did find a thread talking about a similar issue on Mac here, but I did not find an answer to it.

Any idea what the cause for this is?
 

shanedk

Well-known member
May 20, 2018
419
112
Does it work with the other clients, and only fails with the plugin?
 

Jaap

Well-known member
May 20, 2018
121
14
Hey Ipomoea,

Code ERRFE002 happens when the response from the 2nd request to the server (the one with cmd=ident) does not provide a "url".
 

Ipomoea

Member
May 20, 2020
8
0
That is most likely the issue.
I was wondering if the last update of the plugin has anything to do with the error suddenly appearing? I am pretty sure it did not appear when I started my tests and I can't figure out what I might have changed since then to cause its appearance.
 

Jaap

Well-known member
May 20, 2018
121
14
I was wondering if the last update of the plugin has anything to do with the error suddenly appearing? I am pretty sure it did not appear when I started my tests and I can't figure out what I might have changed since then to cause its appearance.
Which update do you mean?
The WebExtension hasn't been updated in quite a while.