An error has occurred


Status
Not open for further replies.

PatrickP61

Active member
Mar 22, 2019
30
8
An error has occurred
Decrypting identity failed, please try with another password. [ok]


What does the above mean?

I successfully logged in yesterday.
But today, I cannot login with SQRL. I keep getting that message.

I have reset my password with the app on my phone, but when I try to use it on this site, it keeps failing.
What am I doing wrong?

Stats: Android 6.0 with SQRL Login installed from Google play store as of 3/21/19.
Error message originates from the app itself when trying to scan a QR code to login.

I had to reset my password at this site to gain access and post this question.
 

kalaspuffar

Well-known member
May 19, 2018
296
106
Sweden
coderinsights.com
Hi Patrick.

First, you are not doing anything wrong.

The error message says that the application was not able to unlock your identity with that password. So the identity on your phone is saved/encrypted/locked with a password. That password is required to unlock that identity.

If you created the identity in another client and then imported it to Android then you used the password during the import process.
If you created the identity on the phone you selected a password when you created the identity and retyped it.

So when you try to login to this forum site you scan the QR code and then input your SQRL / master password. The password connected to your identity. So not a password for this site.

If you forgot your SQRL password or are unsure which one it is. You can reset your password using the recovery code that is connected to the identity on your phone. The long number you got when you created the identity.

I hope this helps, otherwise, just ask again and I or any of the other helpful souls here will help you.

Best regards
Daniel
 

PatrickP61

Active member
Mar 22, 2019
30
8
Hi Daniel

The oddest thing happened. You see i created the identity yesterday and it worked when scanning the qr code on a laptop, but today i kept getting that error message. Just now i decided to visit the forum on my phone and simply pushed three qr code itself. Then entered the sqrl password and it worked. At least on the phone. I'll try scanning the laptop next week and see if the error returns or not.

Patrick
 

kalaspuffar

Well-known member
May 19, 2018
296
106
Sweden
coderinsights.com
Hi Patrick

Strange, that error should be independent on environment. It only occurs if the phone is unable to decrypt your identity.

So if you scan or click a link does not change the scenario. As long as you use the same identity it should work with the same password.

Best regards
Daniel
 

PatrickP61

Active member
Mar 22, 2019
30
8
Ok, I carefully documented my steps since last week.

Quick history:
I created a new identy late last week for the first time and I succeeded in logging in on my android phone and at this forum.
The next day, I tried to do it again and my app on the phone kept failing with the error message noted above.
Then I signed in here at the forum just using a password and posted the question as to what I'm doing wrong.
Saw Daniel's note about not doing anything wrong.
Went home and tried to login to the forum using my phone only, and pushing on the qr code. It worked.

Today, I did the following:
  1. Opened browser with current tabs and the forum was already opened from last week.
  2. Logged out.
  3. Pushed Login
  4. Pushed the SQRL app on my phone to activate the app.
  5. Pushed blue SQRL to activate scanner
  6. Scanned the QR code
  7. Entered my full password on the phone
  8. Saw brief message saying Decrypting. And it appeared to decrypt.
-- NOTHING changed on the forum -- It remained at the login, which I thought was strange!
  1. Pushed the blue SQRL to activate scanner
  2. Scanned the QR code a 2nd time
  3. Entered 1st 4 char of my password.
  4. Decrypting
  5. Successful login with forum screen change.

So I'm wondering if there is some kind of confusion between CHROME and the website or something.
Very strange!
 

PatrickP61

Active member
Mar 22, 2019
30
8
I wanted to attempt the same steps a 2nd time this morning:

  1. logged out
  2. pushed login
  3. pushed SQRL app
  4. pushed blue SQRL to activate scanner
  5. Scanned QR code
  6. Entered my FULL password -- That's strange, why didn't it want only my 1st 4 since it has been about 20 mintues or so.
  7. Decrypting
  8. Successful login.

So the 2nd attemp[t was fine though the mobile phone app asked for my full password and not my abbreviated one. Not a huge deal but is that the desired effect?
 

sengsational

Well-known member
Feb 17, 2019
115
36
@PatrickP61, There's a bug somewhere (not sure if it's the Android client or the web site), where it takes more than one try to get logged into this site. This is getting air time on another thread on this forum.

The default minutes to stay in quickpass mode is only 5 minutes. I presume you increased it, but the ability of the app to stay in quick pass mode is also being discussed as a problem.

So yeah, just bumps in the road. Thanks for the reports.

And as to your OP, I'm not a fan of the wording of that message either. Everywhere else in the world, we just see a message that makes it clear that the app thinks you typed the wrong password. Encryption failed is something that's internal to the app that needn't be exposed.
 

PatrickP61

Active member
Mar 22, 2019
30
8
Hi everyone,
As of the last few days, I've been able to use SQRL without too many problems. I'm satisfied whatever the issue originally was, seems now gone.
 
Status
Not open for further replies.